Tags

, , , , ,

Aww yes, step into the software DeLorean where if you type more than 88wpm you’re favourite software is taken back in time to older, crappier versions you probably have no use for… well, if like me, you can’t type beyond 10.5wpm, OLDERVERSION.com has got your back. Now everyone can go back in time and get useless software.

OLDERVERSION isn’t actually totally useless. There are several reasons you might want to downgrade a program: perhaps you’re more comfortable with an older version, or hate an updated version, or need an older installation with a level of crapyness that matches the crapyness of your old computer. Whatever the case, it’s a cool idea and totally accessible. Have at ‘er people:

…Sadly, it the Software DeLorean can’t go as far back as 1955

Advertisements